[fixed] At times, slow display of offline maps

You can post here if you have found a bug or if you are faced to a strange behavior.
Pascal5

[fixed] At times, slow display of offline maps

Post by Pascal5 » Thu Oct 15, 2020 1:34 pm

A weird behavior, sometimes seen using the latest version 2.2.7. I don't remember seeing it in previous versions.

When scrolling around on an offline map (mine are sqlite stored on SD card), it happens at times that the tile display is slow, with tiles taking several seconds to progressively cover the display area. Grey dots are shown where the tiles are still missing, which turn briefly red just before a tile is shown in that position.

- It happens whatever map I select (including if displaying only the default base map).
- Changing map does not solve the problem.
- Quitting and restarting app does not solve the problem.
- I checked that DEM data download is not selected.
- It happens with or without internet connection.
- The problems suddenly happens at times, randomly, and disappears also randomly, not being able to identify what action causes the problem to start and stop.
- When the problem disappears, all is back to normal, including fast and fluid scrolling around.

Psyberia-Support
Site Admin
Posts: 4950
Joined: Wed Apr 14, 2010 9:41 pm

Re: At times, slow display of offline maps

Post by Psyberia-Support » Thu Oct 15, 2020 3:46 pm

Hi Pascal,
After seeing this problem, could you make an error report from the application so I can check your logs? (main menu -> More -> report errors).
I've made various changes on the background loading of offline maps in version 2.2.7 (to address an old report from you actually), so it may be related.
Do you like AlpineQuest ? Leave a small comment on Google Play !

Pascal5

Re: At times, slow display of offline maps

Post by Pascal5 » Fri Oct 16, 2020 2:56 pm

I have sent you the application.log file, recorded just after having restarted the application, while it was in "slow display mode".

It can be worth noting, my SD card contains some 20 offline maps, totaling almost 200GB of data! Could some background preprocessing done by the app cause SD read saturation, hence slow display?

BTW, the previous issue is now fixed: Now, the app remembers the bounding boxes of my offline maps correctly. Thanks!

Psyberia-Support
Site Admin
Posts: 4950
Joined: Wed Apr 14, 2010 9:41 pm

Re: At times, slow display of offline maps

Post by Psyberia-Support » Wed Oct 21, 2020 7:24 pm

Thanks for the log file. I don't see any particular problem so I think it's related to this issue.
I've started the release of version 2.2.7b for the first users, which does fix it, so let's see if it will work fine when you get it.
Do you like AlpineQuest ? Leave a small comment on Google Play !

Psyberia-Support
Site Admin
Posts: 4950
Joined: Wed Apr 14, 2010 9:41 pm

Re: At times, slow display of offline maps

Post by Psyberia-Support » Sat Oct 24, 2020 8:53 am

I close this issue since the other one has now been conformed as fixed.
Do you like AlpineQuest ? Leave a small comment on Google Play !

Post Reply