[closed] search fails when search location by name

You can post here if you have found a bug or if you are faced to a strange behavior.
tomo
Posts: 1
Joined: Sat Mar 16, 2013 6:10 pm

[closed] search fails when search location by name

Post by tomo » Sat Apr 20, 2013 2:29 pm

I am not able to do a search by location name. I get the following error "The search failed, you need to have an internet data access to search a location by name." I know I have an internet data connection and I am almost sure it worked in the past. I have version 1.3.12 full version. Can you give me any suggestions on what settings I do not have set right or what else I may be doing incorrectly?

Thank You

Psyberia-Support
Site Admin
Posts: 4895
Joined: Wed Apr 14, 2010 9:41 pm

Re: search fails when search location by name

Post by Psyberia-Support » Sun Apr 21, 2013 8:40 pm

Hi,
AlpineQuest uses Google geocoding service to retrieve location by names, over Internet.
This particular message is displayed when the connection to the server failed, usually due to a bad data access. Haven't seen yet another cause yet (other messages are displayed for other issues or null results).
Unfortunately I have not much useful suggestion to give... Have you tried with different access modes, such as 3G or WiFi? Just to double check your Internet access.
Let me know if you can't make it work again.
Best regards
Do you like AlpineQuest ? Leave a small comment on Google Play !

CRider
Posts: 126
Joined: Sat Feb 02, 2013 2:23 pm

Re: search fails when search location by name

Post by CRider » Wed May 29, 2013 8:18 am

Hi,
I've also experienced a search issue a few days ago. I had a poor 3g connection in that location. The search feature instantly returned that I had no network connection.
I've done the same search with Google Maps and it took a long time but the search succeeded.
I've tried again with AQ and it failed immediately.
It looks like AQ does not wait enough for a response from the server.
Later, I was back home and connected via WiFi and the search still failed immediately.
It seems here like AQ has not switched to WiFi.
Restarting my phone fixed the problem : the search via WiFi succeeded.
Regards.

Psyberia-Support
Site Admin
Posts: 4895
Joined: Wed Apr 14, 2010 9:41 pm

Re: search fails when search location by name

Post by Psyberia-Support » Wed May 29, 2013 8:58 am

Hi,
Yes it's actually an Android 4.x bug which is reported here and have been discussed in a previous topic in french.
When the search by name systematically fails, a restart of the device is needed to fix it.
The only way for AlpineQuest to avoid it is not using the Google search API, but it's not yet planned.
Best regards
Do you like AlpineQuest ? Leave a small comment on Google Play !

CRider
Posts: 126
Joined: Sat Feb 02, 2013 2:23 pm

Re: search fails when search location by name

Post by CRider » Wed May 29, 2013 1:23 pm

As Google Maps search succeeded in my case, that means that it does not rely on Google Search API unlike AQ ??
Regards

Psyberia-Support
Site Admin
Posts: 4895
Joined: Wed Apr 14, 2010 9:41 pm

Re: search fails when search location by name

Post by Psyberia-Support » Thu May 30, 2013 8:15 pm

Yes I agree it seems strange but I guess it's the case. Maps must have its own search engine...
Do you like AlpineQuest ? Leave a small comment on Google Play !

Post Reply