[closed] Problems downloading Community map area

Discussions about onboard maps, online maps and Map Creators
Frogfoot
Posts: 9
Joined: Sat Apr 16, 2016 10:23 am

[closed] Problems downloading Community map area

Post by Frogfoot » Sat Apr 16, 2016 11:22 am

Hi,
I'm trying to download 1:50k and 1:25k UK OS maps from the Community OS Explorer series maps. In general it works well.
However I have noticed the following behaviour. If the defined area is within the bounds of the available map all is well and the process is fast and results in a nice green bar denoting that all the tiles have been downloaded. However If the defined area includes tiles that are not in the map (for example in coastal areas) the download will take much longer and will result in a red bar denoting problems downloading some tiles.

If for example I define an area like the South West of England, there are many tiles which are not on the map (as the map is roughly triangular and the defined area is a rectangle.) This means that The download takes a very long time compared to a similar area inland, and I can never be sure all the tiles have been retrieved.


Cheers
Tom

Psyberia-Support
Site Admin
Posts: 4957
Joined: Wed Apr 14, 2010 9:41 pm

Re: Problems downloading Community map area

Post by Psyberia-Support » Wed May 18, 2016 2:11 pm

Hi and sorry for having missed this post!
I've just found it now.

Well, this is in fact the "expected" behavior with current versions.
When inland, all parts are available, so it's smooth and easy. But when you reach the limit of the map, then at some point the map isn't available anymore and the app get nothing. When it happens, it's not always easy for the app to know if it's normal (the map is just not available here), or if an error occurred (the map server is too busy for now or under maintenance, the user has reach a quota, the maps is currently being generated and will be soon available, etc). It really depends on the map server and various conditions. So when there is a doubt, the application will consider that it's an error (that you'll see in the progress bar), AND, it will keep this part apart and try to get it a second time at the end of the process, just in case, and that's why it's taking more time.

Since all failed part are tried two times, it's very rare that some area are missing after the "store area" process, unless there is something wrong with the map server or the device network...

I've just improved this error detection (that will be available in the next update), but there will always be some cases when it's unsure...
Do you like AlpineQuest ? Leave a small comment on Google Play !

Post Reply