[closed] Java.io.IOException: Invalid argument

You can post here if you have found a bug or if you are faced to a strange behavior.
MARTIN33
Posts: 5
Joined: Wed Nov 17, 2010 10:14 pm

[closed] Java.io.IOException: Invalid argument

Post by MARTIN33 » Sat Nov 20, 2010 6:00 pm

This is probably just a memory limit thing but if I have a layer with more than about 100000 tiles I get the above error diplayed all over the area where the map should be. all other layers are still there.

Psyberia-Support
Site Admin
Posts: 4895
Joined: Wed Apr 14, 2010 9:41 pm

Re: Java.io.IOException: Invalid argument

Post by Psyberia-Support » Mon Nov 22, 2010 9:34 am

Hi,
I don't think this is a memory problem. You should be able to load very big maps (few GB maps have been successfully tested).
It seems to be a corrupted map, like if the file is not complete. Maybe you can compare the file size of the map on the SD card and on your computer. Very big maps can take a long time to be entirely copied on the SD card. Moreover depending on how has been formated your SD card, you can be limited to 4GB files.
Le me know if copying again the file solve the issue.
Regards
Do you like AlpineQuest ? Leave a small comment on Google Play !

MARTIN33
Posts: 5
Joined: Wed Nov 17, 2010 10:14 pm

Re: Java.io.IOException: Invalid argument

Post by MARTIN33 » Mon Nov 22, 2010 7:05 pm

I have tried various map sizes, using multi map. and have found that the limit for layer 15 seems to be about 100000 tiles. I'll try a few ather combinations and let you know.

Psyberia-Support
Site Admin
Posts: 4895
Joined: Wed Apr 14, 2010 9:41 pm

Re: Java.io.IOException: Invalid argument

Post by Psyberia-Support » Mon Nov 22, 2010 10:52 pm

Ok you're maybe right.
I'll made test from my side and let you know too.
Thanks
Do you like AlpineQuest ? Leave a small comment on Google Play !

Post Reply