Picture Waypoint just quits

You can post here if you have found a bug or if you are faced to a strange behavior.
Leithal
Posts: 5
Joined: Mon Aug 31, 2020 1:59 am

Picture Waypoint just quits

Post by Leithal » Mon Jan 04, 2021 5:15 pm

Whenever I attempt to create a picture waypoint, the camera flashes briefly then disappears. I've rebooted my phone, etc and the behavior is the same. Pixel 3XL with the latest Android OS/patches.

Online
Psyberia-Support
Site Admin
Posts: 4950
Joined: Wed Apr 14, 2010 9:41 pm

Re: Picture Waypoint just quits

Post by Psyberia-Support » Thu Jan 07, 2021 11:25 am

Hi,
When you ask for a picture waypoint, the application will start the device Camera application and ask for a picture.
It seems that on your device this app fails to work in this mode.
Unfortunately there is little thing we can do from the application point of view. You may try to check if you default Camera apps working fine, or if you can try to use another Camera application.
You can also try to clear the cache and data of your Camera app (from the Android apps settings). Note that even if your pictures should not be affected, it's always important to make a backup when trying things like this.

Alternatively, you can take a regular picture using your Camera app, then create a regular waypoint from the app and associate the picture from the Gallery (in the create waypoint dialog -> More -> Gallery).
I know far from optimal but this is the only workaround I can think of right now.
Sorry about that.
Do you like AlpineQuest ? Leave a small comment on Google Play !

N3Cr0

Re: Picture Waypoint just quits

Post by N3Cr0 » Sun Jan 17, 2021 11:11 pm

Hi there. Love the app! I would like to second this bug though. Also pixel 3 with latest Android and patches.

Camera app starts fine from any other application. Just this one that fails so it really does look like some sort of implementation issue.

Could you possibly take a look at it please? 😊👍

Online
Psyberia-Support
Site Admin
Posts: 4950
Joined: Wed Apr 14, 2010 9:41 pm

Re: Picture Waypoint just quits

Post by Psyberia-Support » Tue Jan 19, 2021 12:07 pm

Hi,
Unfortunately there are no much things to look at, the process of requesting a picture to the default Camera is simple, straightforward, and closely followed by the application.

The application also supports an alternative method, in which the picture will be saved in the main device Pictures folder (along with all other pictures from the Camera, instead of inside the application pictures folder).
But is does not work with all Camera applications. Maybe it will work better on your device. You can activate this method using this user setting:

Code: Select all

core.pictures.use_application_folder=false
Add this line in the existing file "[app folder]/user_settings.conf".
Do you like AlpineQuest ? Leave a small comment on Google Play !

Online
Psyberia-Support
Site Admin
Posts: 4950
Joined: Wed Apr 14, 2010 9:41 pm

Re: Picture Waypoint just quits

Post by Psyberia-Support » Sat Mar 06, 2021 11:07 am

Here is a summary of all gathered information on this subject.

It has been reported that this problem only occurs is the users has chosen the external SD card as a data storage location.
Also, on Android 11, the default Camera application must be available (not turned off in the settings) as this is the only one that can be used.

AlpineQuest versions: all.
Android versions: It seems that the problem only occurs on Android 11 devices.
Known devices: Google Pixel 3, Google Pixel 3 XL, Samsung Galaxy S10+.
Workarounds: Use the internal memory as internal storage, have the default Camera application operational.

Please let us know if you any additional information to share.
Do you like AlpineQuest ? Leave a small comment on Google Play !

Post Reply